Search PADS Maker Documentation

Searching PADS Maker Edition


All PADS Maker Documentation
Skip to end of metadata
Go to start of metadata

Tooltips are short videos showing how commands in PADS Maker Layout work. 

The primary PADS Maker Layout toolbar (Main Toolbar) contains general commands, while the four sub-toolbars organize the majority of commands used to build your design. These toolbars are DraftingDesignDimensioning, and ECO.

Searching PADS Maker Edition

Contents

Main Toolbar


Tooltip Icon Description                                       Extended Text

Open

Description:

Opens a design file (.pcb, .job)

Open PCB design file.                                      

Save

Description:

Saves the design using the current file name

Save PCB design file.

Layer

Description: none

Sets the current active layer

If the "Active Layer Comes to Front" option is enabled under Tools>Options>General, objects which are on the active layer are drawn last and made visible. 

Properties

Description:

Opens the Properties dialog box for the selected item to view or change information

Opens the Properties dialog to review or modify the selected object's properties.

Each object type has its own Properties dialog.

 

Cycle Selection

Description:

Deselects currently selected object and selects a new object at the same location

Cycle through design objects at the point of selection

  1.  Select the desired location on the screen where you wish to select an item.
  2. Choose the cycle selection to toggle selection between items near the location you chose.

Most often an item on the active layer is selected first if multiple items are overlapping. Cycle switches between initially selected item and other objects in the vicinity of the of the chosen location.

Drafting Toolbar

Description:

Hides or shows Drafting Toolbar

Toggles visibility of the Drafting Toolbar

The Drafting toolbar includes the ability to generate 2D Lines, Copper Shapes, Board Outline, Copper Pour Areas and Text Items. Additional capabilities include copper flooding operations and loading shapes from the library.

Design Toolbar

Description:

Hides or shows Design Toolbar

Toggles visibility of the Design Toolbar

The Design Toolbar provides access to primary placement and routing commands.

Dimensioning Toolbar

Description:

Hides or shows Dimensioning Toolbar

Toggles the visibility of the Dimensioning Toolbar

The Dimensioning Toolbar provides access to various commands used to create dimensions to document the design

ECO Toolbar

Description:

Hides or shows the ECO Toolbar

Toggles the visibility of the ECO Toolbar

The ECO Toolbar provides access to utilities to make engineering changes to the design.

The ECO Toolbar includes the ability to rename components and to perform pin swaps and gate swaps dynamically.

Undo

Description:

Undoes the last command

Undoes the last operation

Reverses design state modification performed by the last command, one command at a time.

Redo

Description:

Undoes the last Undo command

Redoes the last operation.

Reverses the effect of any Undo command(s), one command at a time.

Note: All Redo opportunities are cancelled once any command changing the design state is performed.

Zoom

Description:

Toggles between Zoom mode on/off

Toggle the Zoom mode

Select the Zoom icon (to enable the Zoom mode):

           1. Left click to zoom in; the click location moves to the center of the active view. 

           2. Right click to zoom out; the click location moves to the center of the active view.

           3. To exit the Zoom mode, click the Zoom icon again.

Board

Description:

Center the board outline in the window.

Fit the entire board outline area to the active graphic view

  1. Select the Board icon to fit the extents of the board outline into the active graphic view.

Bottom View

Description:

Toggle bottom view.

Mirror the current active graphic view

Toggles between Top Layer view and the Bottom Layer View.

Top Layer view is the default view.

Redraw

Description:

Refreshes the display

Redraws the screen.

Select the Redraw icon to repaint the screen graphics.

Output Window

Description:

Hides or shows the Output Window

Toggle the visibility of the Output Window.

The Output Window provides detailed information on the session events.

Project Explorer Window

Description:

Hides or shows the Project Explorer Window

Toggle the visibility of the Project Explorer Window.

This window includes information on the Layer Stackup, Components, PCB Decals, and Nets.

Drafting Toolbar

Tooltip Icon

 

Description

Select Mode

Description:

Sets object selection mode

Enable object selection mode to select drafting objects within the design.

Once the object is selected, you can perform editing operations on the object(s).

2D Line

Description:

Add a non-electrical drafting shape

Add a line or shape

Select the 2D Line Icon

        1. Press the right mouse button and choose the shape type.

       2. Select the polygon start point.

       3. Select additional boundary points of the polygon.

       4. Select the final boundary point of the polygon and click the right mouse button and the      Complete option to connect the last point with the starting point.

Circle and rectangle shapes require two clicks to complete the command. For Path and Polygon shapes use a double click to complete the command.

Copper

Description:

Create a fixed or non-pour outline

Add a copper shape

Select the Copper icon

  1. Press the right mouse button and choose the shape type.
  2. Select the copper polygon start point.
  3. Select additional boundary points of the polygon.
  4. Select the final boundary point of the polygon and click the right mouse button and the Complete option to connect the last point with the starting point.
  5. Assign the copper shape to net, adjust copper properties in the Add Drafting dialog, press OK.

Circle and rectangle shapes require two clicks to complete the shape. For Path and Polygon shapes use a double click to complete the shape.

Copper Cut Out

Description:

Create a copper cut out area within a copper polygon

Add a copper cut out

Select the Copper Cut Out icon

  1. Press the right mouse button and choose the shape type.
  2. Select the copper cut start point.
  3. Select additional boundary point of the copper out polygon.
  4. Select the final boundary point of the polygon and click the right mouse button and the Complete option to connect the last point with starting point.

Note: Copper pour must be added to a No Plane electrical Layer. Shape types for copper pours are limited to polygon, circle, and rectangle.

Copper Pour Cut Out

Description:

Create a cut out within a copper pour area

Add a copper pour cut out

Select the Copper Pour Cut Out icon

  1. Press the Right Mouse Button and choose the shape type.
  2. Select the copper pour cut out start point on the copper shape.
  3. Select additional boundary points of the copper pour cut out polygon.
  4. Select the final boundary point of the polygon and select the right mouse button and the Complete option to connect the last point with the starting point. 

Note: Copper Pour Cutouts must be added to a No Plane electrical layer. Shape types for copper pour cut outs are limited to polygon, circle, and rectangle.

Board Outline

Description:

Create a board outline or a board cut out.

Add a polygon shape with drafting properties board outline

Select the Board Outline icon

  1. Press the Right Mouse Button and choose the shape type (polygon, circle, or rectangle)
  2. Select the board outline out start point
  3. Select additional boundary points of the board outline
  4. Select the final boundary point of the polygon and select the right mouse button and the Complete option or double click to connect the last point with the starting point.

To create a board cut out, press the Board Outline icon. Answer yes when prompted, "Board Outline exists. Would you like to create a Board Cut Out?".

  1. Press the Right Mouse Button and choose the shape type (polygon, circle, or rectangle)
  2. Select the board outline cut out start point within the board outline.
  3. Select additional boundary points of the board outline cut out.
  4. Select the final boundary point of the polygon and select the right mouse button and the Complete option or double click to connect the last point with the starting point.

Keepout

Description:

Create a keepout area.

Add a Keepout

Select the Keepout icon

  1. Press the Right Mouse Button and choose the shape type (polygon, circle, or rectangle).
  2. Select the keepout starting point.
  3. Select additional boundary points of the keepout.
  4. Select the final boundary point of the polygon and select the right mouse button and the Complete option or double click to connect the last point with the starting point.
  5. In the Add Drafting dialog set your parameters including at least one keepout restriction and press the OK button.

Text

Description:

Create a text item.

Add Text to the active layer

Select the Text icon

  1. In the Add Free Text dialog, set the font, layer, size parameters, justification and other properties.
  2. Add the text to the "Text" field in the Add Free Text dialog.
  3. Select the OK button. The text is attached to the cursor ready for placement.
  4. Right click to set adjust rotation and justification.
  5. Click to place the text in the display area.
  6. The Add Free Text dialog re-appears to add additional text.
  7. To cancel the Add Text mode, select the Cancel button in the dialog or press the Esc key on your keyboard.

Flood

Description:

Flood the selected pour outline.

Generate copper data inside the selected plane area or copper pour area

Select the Flood icon

  1. Click the boundary of a copper pour or plane area you wish to flood
  2. Answer Yes to generate the copper data when prompted with message "Proceed with flood?" or "OK to connect to the plane(s)?"

Get Drafting from Library

Description:

Get a drafting item from the library.

Load a pre-built drafting shape from the Library

 

Select the From Library icon

  1. Set the desired library and use the Items field to filter choices.
  2. Choose the item you wish to add to your design and select the OK button–the item is attached to the cursor.
  3. Click to place the item in the desired location.

Plane Area

Description:

Create a fixed or non-poured plane area outline.

Add a plane area boundary

Select the Plane Area icon

  1. Press the right mouse button and choose the shape type (polygon, circle, or rectangle).
  2. Select the plane area polygon start point.
  3. Select additional boundary points of the polygon.
  4. Select the final boundary point of the polygon and select the right mouse button and the Complete option to connect the last point with the starting point.

Note: Plane Area can only be placed on split/mixed plane layers.

Plane Area Cut Out

Description:

Create a cut out within the plane area

Add a Plane Area cut out on the active layer

Select the Plane Area Out Cut Icon

  1. Press the right mouse button and choose the shape type (polygon, circle, or rectangle)
  2. Select the plane area cut out start point.
  3. Select additional boundary points of the plane cut out polygon.
  4. Select the final boundary point of the polygon and select the right mouse button and the Complete option to connect the last point with the staring point.

Note: Flooding operations do not place copper inside plane area cut out regions.  

Auto Plane Separate

Description:

(Auto separate)

Splits a plane area automatically creating a gap between the areas

  1. Select the starting point on the plane area boundary.
  2. Select the Auto Plane Separate Icon.
  3. Select additional points of the plane separation path.
  4. To complete the separation path, double click on the final plane area boundary point.
  5. Choose the net names for each created shape using the Assign Net to Selected Polygon dialog.

Hatch

Description:

(Redraw the hatch for the selected pour outline)

Fills selected hatch outline with the hatch pattern

Hatch fills in the pre-defined copper areas that have been "cut" around objects.

Select the Hatch icon

  1. Click on the hatch outline to fill in the copper areas.

Selecting the hatch outline first followed by choosing the Hatch icon will also fill in copper areas.

Add New Label

Description:

Add a new part label

Create new text label

Add text label for the selected component to visualize refdes or part attribute.

Select the add new label icon

  1. Click on the part which will receive the new label–the Add New Part dialog opens.
  2. Select the desired item form the Attribute list.
  3. Adjust other parameters as desired.
  4. Select the OK button to place the label at the location specified in the dialog.
  5. If you wish to adjust the label location, right click and select the Move command.
  6. Click again to finalize placement.

Text and Lines Options

Description:

Set text, line width, reference designator options

Open the Options>Drafting>Text and Lines Settings dialog page.

Design Toolbar

Tooltip IconDescription

Select Mode

Description:

Sets object selection mode

Sets object selection mode.

Move

Description:

Move the selected part

Move the selected component(s) to a desired location

Select the Move icon

  1. Select the component–the component attaches to the cursor
  2. Move it to the desired location.
  3. Click to release the component.
  4. Select the Move icon or the ESC key to cancel the command. 

Radial Move

Description:

Move the selected part/union on a polar grid

Move the selected component(s) radially to a desired location

Select the Radial Move icon

  1. Select the component.
  2. Move it to the desired location on the polar grid.
  3. Click to release the component.
  4. Select the Radial Move icon or the ESC key to cancel the command.

Note: Polar grid settings can be found under Tools>Options>Grids and Snap>Grids>Radial Move Setup

Rotate

Description:

Rotate the selected component

Rotate the select component(s) 90 degrees

Select the Rotate icon

  1. Select the component.
  2. Click the component to move it by 90 degrees.
  3. Select the Rotate icon or the ESC key to cancel the command.

Spin

Description:

Spin the selected component

Rotate the selected component(s) in any angle

Select the Spin icon

  1. Select the component.
  2. Spin your cursor to define the desired angle.
  3. Click to set the component location.
  4. Select the Spin icon or the ESC key to cancel the command.

Note: The angle can be seen on the status line at the bottom of the screen.

Swap Part

Description:

Swap the position of the two selected components

Swap the placement of a single component with another

Select the Swap Part icon

  1. Select the first component you wish to swap.
  2. Select the second component you wish to swap.
  3. When prompted select Yes to swap the components.
  4. Select the Swap Part icon or the ESC key to cancel the command.

If the second component you choose is not desired, select No when prompted (the first component remains selected and ready to swap), click on a different component to swap and answer Yes when prompted.

Move Reference Designator

Description:

Move selected label

Move the selected Reference Designator

Select the Move Reference Designator icon

  1. Select the reference designator.
  2. Right click to see options for rotating or spinning.
  3. Click the desired angle if it was modified.
  4. Click to place the reference designator.
  5. Select the Move Reference Designator icon or the ESC key to cancel the command.

Note: Other labels can be moved by this command.

Add Corner

Description:

Add a corner to the selected segment at the cursor position

Edit an existing trace segment to add an additional point

Select the Add Corner icon

  1. Select a trace segment at the location to add a new corner.
  2. Move the cursor to the desired location.
  3. Click to place the new trace corner.
  4. Select the Add Corner icon or the ESC key to cancel the command.

Add corner allows both segment attached to the new corner to move.

Split

Description:

Split the selected segment

Split the selected trace segment

Grows a new segment from the split point.

Select the Split icon

  1. Select a trace segment at the location to split.
  2. Move the cursor to the desired location.
  3. Use Swap in the right mouse button menu to select the opposing segment of the split point for movement.
  4. Select the Split icon or the ESC key to cancel the command.

Split locks down one segment attached to the split point and allows the other segment attached to the split point to move. The swap command allows the previously locked down segment to move with the corner and locks down the other segment.

 

Add Route

Description:

Start routing the selected connection

Start routing the selected connection or from the selected object

Select the Add Route icon

  1. Select the pin, routed trace or unrouted connection to route, use click to change the route direction.
  2. Define the trace geometry by moving the cursor and using the commands in the right mouse button popup window.
  3. Complete routing the trace on the finishing pin or use the right mouse button command to create a partial trace.
  4. Select the Add Route icon or the ESC key to cancel the command.

If a pin pair or an unrouted is selected, the routing starts from the pin/via closet to the selection point. If you're using DRC Off mode the Add Route command is a manual action and obstacles must be avoided or traces must be rerouted later to remove spacing errors.

Dynamic Route

Description:

Dynamically route the selected connection

Dynamically route the select connection

Select the Dynamic Route icon

  1. Select the pin/via, routed trace or unrouted connection to route.
  2. Define the trace geometry by moving the cursor and using the command in the right mouse button popup window.
  3. Complete routing the trace on the finishing pin or use the right mouse button command to create a partial trace.
  4. Select the Dynamic Route icon or the ESC key to cancel the command.

Dynamic Route requires DRC Prevent mode to be active. To enable DRC Prevent mode type "DRP <enter>". To disable DRC move type "DRO <enter>" for DRC Off mode. Dynamic Route uses automated clearance checking during interactive actions to avoid errors due to design rule violations.

Sketch Route

Description:

{Move the selected route)

Quickly rerouted of existing trace by drawing a sketch line

Select the Sketch Route icon

  1. Select the trace to reroute.
  2. Draw a sketch line with the cursor to indicate the new desired path, and click to initiate the reroute sequence.
  3. Select the Sketch Route icon or the ESC key to cancel the command.

Sketch Route requires DRC Prevent mode to be active. To enable DRC Prevent mode type "DRP <enter>". To disable DRC move, type "DRO <enter>" for DRC Off mode. Sketch Route uses automated clearance checking during interactive actions to avoid errors due to design rule violations.

Auto Route

Description:

Automatically route a connection.

Automatically route a selected connection

Select the Auto Route icon

  1. Select the trace/connection/unroute to automatically route.
  2. Select the Auto Route icon or the ESC key to cancel the command.

Auto Route requires DRC Prevent mode to be active. To enable DRC Prevent  mode type "DRP <enter>". To displace DRC move type "DRO  <enter>" for DRC Off mode. Auto Route uses automated clearance checking during interactive actions to avoid errors due to design rule violations.

Bus Route

Description:

Bus route the selected connections

Route selected connections simultaneously

  1. Use Ctrl-Click to select the pins of the routes you wish to route simultaneously.
  2. Select the Bus Route icon.
  3. Move the cursor and use the commands in the right mouse button popup window to define the location for the first trace segment and click. The first trace will be placed and the traces for the other routes will be automatically placed.
  4. Continue to click to place the "guide" trace closer to the desired destination and the other traces will follow.
  5. Complete routing the trace on the finishing pin or use the right mouse button commands to create partial traces.
  6. Select the Bus Route icon or the ESC key to cancel the command.

Bus Route requires DRC Prevent mode to be active. To enable DRC Prevent mode type "DRP <enter>". To disable DRC move, type "DRO <enter>" for DRC Off mode. Bus Route uses automated clearance checking during interactive actions to avoid errors due to design rule violations.

Add Jumper

Description:

Add a jumper

Add a jumper

Select the Add Jumper icon

  1. Select the first trace or via to add the jumper.
  2. Move the cursor which displays the outline of the jumper.
  3. Select the final location on the same trace path to complete the jumper.
  4. The Jumper reference designator will be visible.
  5. Select the Add Jumper icon or the ESC key to cancel the command.

Add Test Point

Description:

Add a test point at the selected pin or via

Add a test point at a selected pin or via

Select the Add Test Point icon

  1. Click on the pin or via.
  2. A test point marker will appear.
  3. The properties for the pin or via will show that the test point attribute is enabled and a test point marker will be visible.
  4. Select the Add Test Point icon or the ESC key to cancel the command.

If a trace is selected a new via will be added to the trace and the test point attribute will be enabled. If a surface mount pin is selected the test point and top/bottom access attributes will be enabled.

Design Options

Description:

Design Options

Open the Options > Design dialog page.

Dimension Toolbar

Tooltip IconDescription

Select Mode

Description:

Sets object selection mode

Enable object selection mode.

Autodimension

Description:

Automatically dimension the selected item

Automatically dimensions the selected object

Select the Autodimensioning icon

  1. Click to select a segment, arc, or circle.
    Move the cursor to define the desired location for the dimensioning text.
  2. Click to place the leader lines and dimensioning text.
  3. Select the Autodimensioning icon or the ESC key to cancel the command.

Horizontal

Description:

Horizontal dimension the selected item

Place horizontal dimension

Select the Horizontal icon

  1. Click on the horizontal segment to initiate dimensioning.
  2. Click to place the leader lines and dimensioning text.
  3. Select the Horizontal icon or the ESC key to cancel the command.

Vertical

Description:

Vertical dimension the selected item

Place a vertical dimension

Select the Vertical icon

  1. Click on the vertical segment to initiate dimensioning.
  2. Click to place the leader lines and dimensioning text.
  3. Select the Vertical icon or the ESC key to cancel the command.

Aligned

Description:

Align dimension the selected item

Place a dimension at the same angle as the selected line or points

Select the Aligned icon

  1. Click on a segment to initiate dimensioning.
  2. Click to place the leader lines and dimensioning text.
  3. Select the Aligned icon or the ESC key to cancel the command.

Rotated

Description:

Rotate dimension the selected item

Place a dimension that measures a distance long the specified direction

Select the Rotated icon

  1. Click on the object(s) to initiate dimensioning.
  2. When prompted with the Angle Rotate dialog confirm or change the angle of the dimensioning text that will appear.
  3. Click to place the leader lines and dimensioning text.
  4. Select the Aligned icon or the ESC key to cancel the command.

Angular

Description:

Measure angle

Place dimension that measures the angle between two straight segments

Select the Angular icon

  1. Click on the two segments to initiate dimensioning.
  2. Click to place the leader lines and dimensioning text.
  3. Select the Angular icon or the ESC key to cancel the command.

Arc

Description:

Circle dimension the selected item

Place a dimension that measures arcs or circles using the radius or diameter of the selected object

Select the Arc icon

  1. Click on arc or circle to initiate dimensioning.
  2. Click to place the leader lines and dimensioning text.
  3. Select the Arc icon or the ESC key to cancel the command.

Leader

Description:

Create a leader line

Create a standard pointer to the selected object or point

Select the Leader icon

  1. Click on the object(s) to annotate with a leader line and text.
  2. Use the cursor to extend the leader line to the desired length and double click to finalize the leader line shape.
  3. Enter in the leader line text and select the OK button.
  4. Select the Leader icon or the ESC key to cancel the command.

ECO Toolbar

Tooltip IconDescription

Select Mode

Description:

Sets object selection mode

Enable object selection mode.

Rename Component

Description:

Rename the selected component

Rename the selected component

Select the Rename Component icon

  1. Select component to rename.
  2. Enter the new reference designator when prompted by the Rename Part dialog.
  3. Select the OK button.
  4. Proceed with renaming the next component or press ESC to cancel the Rename mode.

Swap Pin

Description:

Swap the selected pins

Swap the selected pins

Select the Swap Pin icon

  1. Click on the first pin to swap–pins swappable with the selected pin are are hightlighted.
  2. Select the second pin to swap among those highlighted. This action initiates the swap.
  3. Reselect the Swap Pin icon or the ESC key on your keyboard to exit the command.

Swap Gate

Description:

Swap the selected gates

Swap the selected gates

Select the Swap Gate icon

  1. Click on the first gate to swap–gates swappable with the selected one are highlighted.
  2. Select the second gate to swap which initiates the swap.
  3. Reselect the Swap Gate icon or the ESC key on your keyboard to exit the command.

Note: You can swap gates from different components.

Output Window Toolbar

Tooltip IconDescription

Back

Takes the user back a step.

Forward

Takes the user forward a step.

Stop

Stops a process.

Refresh

Refresh the layout session log file.

Home

Snap to the last made command within the layout session.

Clear Log

Clear all information within the current session of the layout session log file.

Print

Print the layout session log file.

Open the Print dialog to select accessible printers and configure printer output.

Search

Search output window.

Open the Find dialog to search for an object

Select the Search icon

  1. Enter the text to use for searching.
  2. Select the parameters such as searching for the entire word, matching case, and highlighting matched text.
  3. Select the Next button or the Previous button to locate the items.

Log to File

Write the output window to a log file.

Show All

Turn on/off the layout session information in the output window

Select the Show All icon to toggle the session information in the output window.

Decal Editor Toolbars

Tooltip IconDescription

Open

Description:

Get decal from library

Open decal from library.

Save

Description:

Quick save the decal to the originating library

Saves decal to the active library.

Layer

Description:  none

Sets the active layer in the decal editor

If the "Active Layer Comes to Front" option is enabled under Tools\Options\General, objects which are on the active layer are drawn last and made visible.

Terminal

Description:

Create a terminal

Create a terminal

Adds a new terminal (pin) to the deca. 

Select the create terminal icon

  1. Define the pin numbering scheme.
  2. Select the desired location to place the terminal in the decal.
  3. Click to place the next pin or select ESC to cancel the Create Terminal command.

Add New Label

Description:

Create a New Label

Create new text label.

Add Text to the decal defined by the Add New Part label dialog

Select the add new label icon.

  1. Select the desired item from the Attribute list.
  2. Adjust other parameters as desired.
  3. Select the OK button, and the label appears at the location specified in the dialog, selected and highlighted.
  4. If you wish to adjust the label location, right click and select the Move command.
  5. Click again to finalize placement.
  • No labels