Skip to end of metadata
Go to start of metadata
With PADS Professional VX1.1 and above, you can connect to PartQuest to import part data. You can import property data into xDX Databook, while CAD data must be imported through xDM Library Tools in EDX format.

Installing PartQuest Professional Utilities

PADS requires a one-time installation of PartQuest Professional utilities before you can begin importing parts. You can download the utilities from the PartQuest site.
After installing the utilities, restart Designer so that it can connect to the PartQuest utility.

Setup PartQuest, Setup Configuration, Import Parts to Library and View Parts without or with Databook

  1. In PartQuest, be sure to download & install the integration utility for PADS Professional to your computer.
  2. In your PartQuest Profiile, be sure you have selected PADS Professional as your default flow.
  3. Select either Direct Download or Dropbox as your download location.  Direct download allows you to select the location on your computer but the default is C:\PADS Projects\PartQuest/PADS_Professional.  Dropbox download will go to Dropbox/Apps/PartQuest/PADS_Professional.
  4. Optional step:  Create a new Partition in your PQ profile.

    For each part you download follow the next steps:

  5.  Search & Select a part from PartQuest and download the symbol and footprint.   If you selected Dropbox in your PartQuest Profile, the data will be downloaded to your Dropbox folder.  If you select Direct Download in your PartQuest profile, the download will go to the folder you select below. 
    1. If using Direct Download, double click on the *.pqz file located in your Downloads folder.  The first time, you will be asked where you'd like to save it.  This location will have a PADS_Integrated directory underneath.   If using Dropbox, this step is not required.
  6. Open PADS Designer Schematic software, create a project or use an existing project, and select Tools > Import PartQuest Parts.  The first time you will be asked to Browse to the folder selected to store your CAD parts from PartQuest.

For Dropbox: select the directory location  Dropbox/Apps/PartQuest/PADS_Professional.   

For Direct Download select the folder selected earlier when you clicked the pqz file (default is  C:\PADS Projects\PartQuest)  Designer will ask you to confirm the location of your parts to import. Select "Yes".   

7. You will be notified where the downloaded data will be saved.  Select OK.

8.  You will be notified that a database connector file (.dbc) will be located in your WDIR.  Select OK.

9.  You will be asked if you want to import the data to your project library.  Since you are running PADS Professional with a central library this doesn't apply.  Select Yes.   

Look in the Output Window and note the text confirmation of the import process. 

10.  PADS Professional has a central library.  If you create a new partition in PartQuest, it will be automatically created in your Central Library.

11.  If you have Databook follow the 2 steps below:

#1  Select Setup > Settings dialog, go to the PADS Databook configuration and browse to the WDIR/PartQuest directory.  The default location is C:\PADS Projects\PartQuest.  Choose the .dbc file, which is named PartQuest.dbc by default. 

#2.  While still under Setup > Settings go to PADS Databook Data Source and under Data Source select PartQuest(.dbc name) and select OK.

12.  Select View/PADS Databook to show the PADS Databook tab at the bottom.  (one time only per project)

13.  If not running Databook, select the PADS Databook tab to select a Library part.  Open your Library Symbol in the PADS Databook window.   Note the newly created partition which by default is called PartQuest (Alias name). 

14.  If you are running Databook, select the Binoculars icon New Search Window icon and select the partition of your choice from the drop-down Library list.

15.  Optional  Use an existing database configuration with PartQuest database

If you would like to use an existing database configuration with the PartQuest database, you can change the target .dbc file by editing the DatabookDBCFile entry in the %WDIR%\PartQuest\PartQuest.ini file to an existing .dbc file that has already been populated.

The PartQuest.ini file is used to configure the settings for the UseSymbolFromCL option, which is one setting option among many. When a PartQuest import occurs, a new Databook table is created (see the Capacitor_PQ image below).  If the UseSymbolFromCL in the PartQuest.ini is set to 1, the "Use symbol data from Central Library will be checked. Otherwise, if the UseSymbolFromCL is set to 0, the Use symbol data from Central Library will be unchecked. 

 

Icon

Note that successive imports will still write to the default database file (PartQuest.mdb) as before, but the custom .dbc file specified will be updated with the new tables, which will reference the PartQuest.mdb file. In other words, the PartQuest import will edit your .dbc file to point at the PartQuest database in addition to the one you have specified. Both PartQuest tables and your custom tables will show up in the dropdown list in Databook.

Importing CAD Data through PADS Library Tools

When downloading a part with CAD data, you will need to import the associated EDX file into xDM Library Tools.

  1. In xDX Designer, go to Tools > PADS Library Tools to open the PADS Library Tools.
  2. Select File > Import EDX.
  3. Browse for and select the .edx file provided in your PartQuest part download (located in either your Dropbox directory or the location you have configured for direct downloads to extract to). Click OK.
  4. Select the PartQuest Library Archive container if prompted, then click OK.
Icon

If you've already imported your property data before your CAD data, you will need to go to Tools > Update Libraries in Designer to see your imported CAD data.

Importing Property Data through Databook

When connecting to your PartQuest database, you can either use the Databook database configuration that PartQuest generates by default, or use an already existing database configuration. Both options are outlined below.

Letting PartQuest generate database configuration and database

If you would prefer to use the default configuration, use the following instructions to connect to your PartQuest symbol library.
  1. In Designer, go to Setup > Settings > Databook.  
  2. Browse to the wdir PartQuest directory (the default location is C:\PADS Projects\PartQuest).
  3. Choose the .dbc file, which is named PartQuest.dbc by default.

Your system is now set up. You can now download new parts from PartQuest and use Tools > Import PartQuest Parts to sync your property data. To import part CAD data, see Importing CAD Data through xDM Library Tools.

Using existing database configuration with PartQuest database

If you would like to use an existing database configuration with the PartQuest database, you can change the target .dbc file by editing the DatabookDBCFile entry in the %WDIR%\PartQuest\PartQuest.ini file to an existing .dbc file that has already been populated.

Icon

Note that successive imports will still write to the default database file (PartQuest.mdb) as before, but the custom .dbc file specified will be updated with the new tables, which will reference the PartQuest.mdb file. In other words, the PartQuest import will edit your .dbc file to point at the PartQuest database in addition to the one you have specified. Both PartQuest tables and your custom tables will show up in the dropdown list in xDX Databook.

  • No labels